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Let’s Get Started... 
Hi there. If you’re reading this, we both known why you are here. You have 
decided to come over to the dark side and join the ranks of indie game 
developers who have done the most horrible, terrifying, disgusting thing in the 
world! You have dared to leave the sheep herd and go down the less traveled 
road. You have decided to become an entrepreneur. 
 
I have a tidbit of hope for you wanna-be entrepreneurs. Have you ever wondered 
how most of the giant companies around the world got started? Do you know 
who runs these companies? Entrepreneurs! I guarantee if you look at the top 
CEOs around the world, you will find that most of them did not work their way up 
the corporate ladder in one company. We are taught from age 5 that the way to 
success is to work hard at the same company for 30 years, and maybe, just 
maybe we might gain access to a senior-level position when we turn 60. Wow, 
what a bummer! How boring! There is a very simply way to circumvent this 
extremely long road: start your own little company and build something great. If 
you do this, the giant companies will come knocking at your door and before you 
know it, if you choose to enter the corporate rat-race, you’ll get to start out much 
closer to the top. Woot! 
 
Why does this matter? I suspect LOTS of you would love to work in the games 
industry. And I’m sure that as we both know, getting into the industry is about as 
easy as winning the lottery. Unless of course, you make a great game on your 
own. Trust me, if you make something awesome that is popular, everyone will 
want to hire you.  
 
Okay, enough of this fluffy stuff. It’s time for you to put on your combat boots. I 
assume you’ve already created your game, so this guide is going to show you 
what to do after you’ve created your game. In a nutshell you need to take 
these steps: 
 

1. Beta test your game (1 month) 
2. Get a business license in your state, and city ($75-???) 
3. Get a website for your game (free) 
4. Get hosting for your game (free) 
5. Get an installer for your game (free) 
6. Get a digital rights management system (DRM) for your game ($300) 

-or- 
Create a demo for your game (free) 

7. Get an order processor for your game (free) 
8. Sell your game! 
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Beta Test Your Game! 
Beta test = letting 10-20 people play your game from the beginning to the end. 
While they play, they should report bugs for you to fix.  
 
NEVER SELL A GAME BEFORE YOU’VE BETA TESTED IT. 
 
My advice is to get yourself a forum (there are free ones that you can get all over 
the web), and use it to collect bugs from your testers. Beta testing should take 1 
month. 1 week is a horrible idea, 2 weeks is almost as bad. 3 weeks is okay, but 
to make sure you game is really clean, go for a month-long beta period. 
 
So, where are you going to find beta testers? The first place to look is in the 
communities where you plan to sell your games. Find players who you think 
would be interested in your game and PM them. Where do you hang out for fun? 
This could be a good place to start. 
 
When I select beta testers a game, I look for these qualities: 
 

 Chatters. Extremely social people love to communicate (obviously!), and 
these folks can give you great feedback. They are more likely to play your 
game and actually tell you what they think. A great way to find chatters is 
to go to communities where people are playing your type of game and PM 
them. I try to have at least 15 chatters as beta testers. 

 Smashers. You need at least one or two really technical people who are 
insanely driven to test every technical aspect of your game. To these 
folks, the fun part of the game is breaking your creature. An error code is a 
big win for these folks. I try to have three smashers as beta testers. 

 Innocents. Innocents are people who have never played a game in their 
life. These people are amazing as they will find every confusing aspect of 
your game that you never thought existed. You only need one or two of 
these precious individuals, but they are the most important beta testers. If 
an Innocent tells you that something is confusing, don’t roll your eyes. 
Listen and fix it. Innocents capture everything that could possibly make 
your game not sell due to your design decisions. 

 
If you have all of your beta testers start at the same time, you will run into one 
major problem:  they will likely find the same bugs, you will fix these bugs, and no 
one will go back to check if these bugs were in fact fixed. 
 
Once you have selected your beta testers, split them into two groups. Have 
group one begin testing in week one. Have group two begin testing in week 
three. This will ensure that any new bugs that you created in week two are picked 
up by your second group of beta testers in week three. 
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Don’t be Stupid & Get Sued 
Sorry, but I had to add this. These are very stupid things to do which could cause 
you to get sued: 

 Use a pirated version of a game engine 

 Use someone else’s graphics, music, or code without their approval 

Get a Business License 
 Cost = Depends on your location, but usually under $100 

 
Before you begin selling anything, you MUST get a business license. The steps 
to obtaining a business license is different in every country.  
 
In the USA, you should create a sole-proprietorship business and get two 
things: 

 State License  

 City License 
 
If you are somewhere else, you need to go to your government website to see 
what permits you need to get. The rest of this section is dedicated to people in 
the USA. 
 
If you are in the USA, to figure out what licenses you need to get, go here: 
http://www.business.gov/register/licenses-and-permits/ 
 
Your state license will probably cost around $50 and your city license will be 
around $25. Some states don’t have city licenses. If the who business license 
stuff is confusing, have an accountant or lawyer get these things set up for you. 
 
Note: You do not need an EIN from the federal government if you are a sole-
proprietorship. 

http://www.business.gov/register/licenses-and-permits/
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Get a Website 
 Cost = $0 

 My suggestion = wordpress.org or wix.com  
 
After you’ve got yourself a business license, get yourself a website. Personally, I 
suggest WordPress or Wix because you don’t need to do any programming to 
create your website. 
 
When you create your website, you should include the following items for your 
game: 

o Logo for game 
o 2 screenshots of game 
o Download button (links to your game on your file hosting service) 
o Buy Now button (links to your Plimus purchase page) 
o Brief description of your game. (1 paragraph) 
o Specs for your game (Win98+, Game Size in MB, RAM, Video)  

 

Host your Game 
 Cost = $0 

 My suggestion = mediafire.com 
 
It’s generally not a good idea keep your game in the same place where your 
website is located. Most website hosting companies won’t allow you to upload 
your game, or they will turn off your site if your game gets too popular and eats 
up bandwidth (more downloads = more bandwidth used). Also, if your game gets 
popular and it’s in the same place as your website, this can bring your website to 
a crawl or crash it. 
 
To avoid this problem, use a file hosting service to store your game. My favorite 
is Mediafire because you can have a free account or a paid account. The free 
account spams your players with an ad before they download. The paid account 
does not. 
 
Go here to set up an account: 
http://www.mediafire.com  
 

Get an Installer 
 Cost = $0 - $199 (depends upon your license) 

 My suggestion = CreateInstall 
 

http://www.mediafire.com/


7 | P a g e  
 

You need an installer for your game to make it look professional. An installer is 
the program you see whenever you download an application or game to your 
computer. It’s the thing that asks you where you want to install the game. 
 
My favorite installer is CreateInstall because it is easy to use, looks nice, and it 
supports many languages, including Japanese. You can get it here: 
http://www.createinstall.com/ 
 
This installer doesn’t require any programming. Just install it, create a new 
project, and drop the file structure of your game into it. Then press the build 
game. Poof! Installer created! The installer for your game is what you should put 
on your website. 
 
This tutorial is going to use a sample game called Sword Quest. Here is the data 
we are going to use: 

 Name of Game:  
Sword Quest 

 Installer Project Location:  
C:\Amanda\Documents\Sword Quest\Installer 

 Game Location:  
C:\Amanda\Documents\Sword Quest\Game 

 Order Page Link Location:  
C:\Amanda\Documents\Sword Quest\Installer\BuySwordQuest.lnk 

 Game EXE Location:  
C:\Amanda\Documents\Sword Quest\Game\Game.exe 

 
Complete these preliminary steps before you create your installer: 
 

1. Create a folder where you want to keep your installer project and your 
installer EXE. For example: C:\Amanda\Documents\Sword Quest\Installer 

2. In your installer project folder, create a text file for your EULA. For 
example: C:\Amanda\Documents\Sword Quest\Installer\EULA.txt 

3. In the folder that contains your game, add a file that links to your order 
page. To do this: 

a. Go to the folder for your game. For example: 
C:\Amanda\Documents\Sword Quest\Game 

b. Click New > Shortcut. The Shortcut dialog box opens. In the 
Location field, enter the link to your game on Plimus. For example: 

http://www.createinstall.com/
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https://www.plimus.com/jsp/buynow.jsp?contractId=0000000  

  
c. Click Next. 
d. In the Name field, enter the name for your link. For example: 

BuySwordQuest. 

 
e. Click Finish. A new shortcut file called BuySwordQuest.lnk is 

created. If you click on it, it should open the Plimus Order webpage 
for your game. 

 
Follow these steps to create an installer with CreateInstall Freeware: 
 

1. Download CreateInstall Freeware:  
http://www.createinstall.com/ 

2. Install CreateInstall Freeware. 
3. Open CreateInstall Freeware. 
4. The New Project dialog box opens. (If it doesn’t, click New icon) 
5. Enter the name of your game and the location where you want to save 

your installer project, then click OK.  

http://www.createinstall.com/
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6. Click Project tab > Output. Enter the location where you want to store the 
installer that players will download, and the name of the installer EXE. 

 
 
 

7. Click Install Script tab > Output.  
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8. If you would like to add an End-User License Agreement (EULA) to your 
installer: 

 
a. In your install project, on the left, expand Dialogs and double-click 

Dialog-License. This adds an active Dialog-License to your 
project. 

b. In the License File field, select your EULA’s text file. 
 

9. Expand the Install > Dialog Progress folders, and select Installation 
Files. This opens the Installation Files page.  
 

10. In the Source Files section, click the New icon. This opens the Edit dialog 
box. In the File field, enter the location of the folder that contains your 
game. 
 

11. Click OK. The Edit dialog box closes and you should see a page that 
looks like this: 
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12. Expand the Install > Dialog Progress folders, and select Shortcuts 
[List]. This opens the Shortcuts [List] page. On this page, we are going to 
add these shortcuts to our game: 

a. A link to game on Desktop. 
b. A link to the game in the Start Menu. 
c. A link to the game’s Purchase webpage in the Start Menu.  

(You created this in the preliminary steps) 
 

13. In the Shortcut [List] page, click the New icon. This opens the New dialog 
box. Enter the Desktop link for your game. When you are done, click OK. 
For example: 
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14. In the Shortcut [List] page, click the New icon. This opens the New dialog 
box. Enter the Start Menu link for your game. When you are done, click 
OK. For example: 

 
 

15. In the Shortcut [List] page, click the New icon. This opens the New dialog 
box. Enter the Start Menu link for your game’s order page. When you are 
done, click OK. For example: 
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16. When you are done, the Shortcut [List] page should look like this: 

 
 

17.  Next, let’s give the player the option to launch the game after the 
installation is complete. To do this, let’s add these commands to the 
installer: Run Application, Set Variables 
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a. On the left side of the Install Script tab, in the command list, expand 
Variables and double-click Set Variables. This adds the Set 
Variable file to the Install folder structure on the right.  

b. On the left side of the Install Script tab, in the command list, expand 
Application and double-click Run Application. This adds the Run 
Application file to the Install folder structure on the right.  

c. In the Install folder, move the Run Application and Set Variables 
files into the following position: 
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18. In the Installer folder, click Set Variables. This opens the Set Variable 
page. 
 

19. On the Set Variable page, click the New icon. The New dialog box opens. 
Add the following settings and click OK. 

 
 



16 | P a g e  
 

20. The Set Variable page should now look like this: 

 
 

21. In the Installer folder, click Run Application. The Run Application page 
opens. Enter the following 
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information:

 
 

22. Click Build Setup. Your installer is created!  
 

23. Test your installer. Make sure your links open the correct files and that the 
game opens when the installer finishes. 
 

Upload Installer to Website 
Yes, it may seem obvious, but... once you’ve create the installer for your game, 
you should upload is to website. So... 

1. Go to the directory where your installer is located. 
2. Upload this installer to your website. 
3. Note the place where you uploaded this installer. For example: 

http://NinjaSwordGames/SwordQuest.exe 
 

http://ninjaswordgames/SwordQuest.exe
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Protect Your Game 
You are reading this because you don’t want to give away your game for free. 
You don’t want users to play your full game without paying you for it. The 
solution? You need let users “test drive” your game, but not finish your game. 
 
Here are two popular try-before-you-buy methods: 

 Let the user play for a specific period of time and then nuke the game. 
Once the game is nuked, it will no longer run until the user purchases the 
game. (DRM) 

 Let the user play a small part of the game. The user can play this part over 
and over again, but not get further in the game. (Demo) 

Use DRM 

 DRM Cost = $300 (Software Passport no longer sold) 

 DRM suggestion = SoftwarePassport 
 
DRM? What the heck is this thing?!? DRM stands for Digital Rights Management. 
You use it to limit how long a user can play your game.  
 
DRM works like this: 
 

1. User downloads game & installs (23 MB) 
2. User plays for one hour. After one hour, the game will no longer play and 

the User is told they can continue to play the game if they purchase it. 
3. User purchases game 
4. You send User an unlock code. 
5. User enters unlock code into game. 
6. User plays full-version of game. 

 
DRM has the following advantages over a demo:  
 

 No need to have both a demo EXE and full-version EXE on your website. 

 User can’t pass around full-version of game to everyone. With DRM, if the 
User moves the game to any other computer, the game can only be 
played for 1 hour and then the “Buy Me” prompt appears. 

 User can instantly continue game after purchase. No need for user to 
download two games. 

 
What the DRM in this tutorial does: 
 

 When your game loads and unloads, a small pop-up window appears 
which asks the User if they would like to Buy the game. This button is 
linked to your order page on Plimus. 



19 | P a g e  
 

 This same pop-up window has an Enter Key button. When the User clicks 
this button, the user can enter a key to make the pop-up window go away 
forever. 

 After 1 hour, the DRM will stop the User from playing your game. The user 
must purchase the game to continue. 

 
Ready to wrap your Game.exe with a snuggly DRM wrapper? Let’s get started! 

Wrap Your Game with DRM 

Use these steps ONLY if you already own SoftwarePassport. As of 2013, this 
product is no longer sold. There are other similar products on the web, but I’ve 
not tried them out. 

1. Go to the Silicon Realms website and purchase SoftwarePassport Win32. 
http://www.siliconrealms.com/ 

2. Open SoftwarePassport. 
3. Click New Fast Project Protect 
4. Click File > Save Project As 
5. Create a folder on your computer for your SoftwarePassport project & 

save your project. 
6. Make a copy of your Game.exe and put it in the folder that contains your 

SoftwarePassport project. 
7. In the ARM filename field, enter the name of your project. 

for example: Sword_Quest 
8. In the Files to Protect field, click + and add your Game.exe (the one in 

your SoftwarePassport folder) 
9. In the Encryption Key field, enter a random value like this: 

Bhjjeiodnkiefkllsdk 
10. At the top of the page, Click Advanced Protect 
11. When the little dialog box opens, click Yes. 
12. By default, the Protection Information tab opens. 
13. In the Application Version field, enter 1.0 
14. In the Website field, enter the URL to your website.  

For example: http://ninjasword.com 
15. In the Application Splash Screen drop-down list,  

select No Splash Screen 
16. Click on the License Certificate tab. 
17. In the Existing License Certificate List, select PurchasedLicense 
18. Click Unlock. 
19. In the Key Style drop-down list, select Standard 
20. In the Key Type drop-down list, select ShortV3 
21. Mark the Allow Key Strings checkbox. 
22. Save your changes. 
23. Click on the Key Expiration tab within the License Certificate tab. 
24. In the Existing License Certificate List, select TrialLicense 
25. Click Unlock. 
26. Mark the Does Key Expire checkbox. 

http://www.siliconrealms.com/
http://ninjasword.com/
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27. Mark the Time after key entered checkbox. 
28. In the Maximum time per run field, enter: 01:00:00 
29. In the Maximum total time field, enter: 00:01:00:00 
30. Mark the Nuke program when timer expires checkbox. 
31. Mark the Full screen capability checkbox. 
32. Save your changes. 
33. Click on the Reminder Screens tab within the License Certificate tab. 
34. Mark the Reminder Message, Expire Message, and Purchase 

Reminder checkboxes. 
Note: You can click on the orange bubbles to format your messages. You 
can use HTML, text, or bitmaps. Your messages will appear in the pop-up 
dialog boxes when your game starts, the player closes, the game, or the 
game expires. If you use HTML, these code snippets are very helpful: 

 <img src="file:///%PROTECTEDFILEPATH%images/buy.gif"  alt="" 
width="165" height="43" border="0"></a> 

 <a href="close:website"> — link to order page 

 <a href="close:ok"> — close dialog box & play game 

 <a href="close:enterkey"> — link to unlock game 

 %DAYSLEFT% — time left before trial runs out 
35. Click on the Build Project tab. 
36. Click Protect. 
37. Your Game.exe is wrapped with DRM! 
38. Drag your DRM-wrapped Game.exe into your game project. This exe 

should overwrite your existing Game.exe. 
 
Note: If you ever need to retrieve your original Game.exe, go to your 
SoftwarePassport Project folder and rename Game.exe.PreARM to Game.exe. 
This is your original exe.  
 
Note: If you need a template for your SoftwarePassport project, let me know and 
I’ll email one to you. My email is admin@amaranthia.com 
 

Use Demo 

 Demo Cost = Free 
 
A Demo is a part of your game that a user can play. You use it to limit how far the 
user can play in your game. 
 
A demo works like this: 
 

1. User downloads demo & installs (5 MB) 
2. User plays demo 
3. User purchases game 
4. You send User a link to the full-version of the game 

mailto:admin@amaranthia.com


21 | P a g e  
 

5. User uninstalls Demo 
6. User downloads full-version & installs (23 MB) 
7. User plays full-version of game. 

 
Demo has the following advantages over DRM: 
 

 Free! 

 No problems with anti-virus vendors flagging your game as a virus. (DRM-
wrapped games are sometimes mistaken as viruses) 

 
What else does Demo bring to the table? 
 

 Customize demo so that some features are disabled. 

 When your game loads and unloads, a small pop-up window appears 
which asks the User if they would like to Buy the game. This button is 
linked to your order page on Plimus. 

 This same pop-up window has an Enter Key button. When the User clicks 
this button, the user can enter a key to make the pop-up window go away 
forever. 

 After 1 hour, the DRM will stop the User from playing your game. The user 
must purchase the game to continue. 

 
What the Demo in this tutorial does: 
 

 When your game loads and unloads, a small pop-up window appears 
which asks the User if they would like to Buy the game. This button is 
linked to your order page on Plimus. 

Create Your Demo’s Buy Now Page 

 
1. Create a folder on your desktop called MyDemo. 
2. Put the following images into this folder: 

 title.jpg (a picture of your game’s logo. 500x100) 

 buy.jpg (a picture of your “buy now” button. 167x43) 
3. Click New Fast Project Protect 
4. Click File > Save Project As 
5. Open an empty text file in a text editor like Notepad. Copy and paste the 

following code into the editor. When you are done, save the file in the 
MyDemo folder as style.css 

 
.prodName { font-family: Verdana, Arial, Helvetica, sans-serif;  

            font-size: 18px;  

            color: #666666;  

            font-weight: bold; }  

 

.prodPrice {font-family: Verdana, Arial, Helvetica, sans-serif;  

            font-size: 36px;  

            color: #009900;  
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            font-weight: bold; } 

 

.website { font-family: Verdana, Arial, Helvetica, sans-serif;  

           font-size: 18px;  

           color: #009900;  

           font-weight: bold; } 

 

.website A:visited {COLOR: #009900; TEXT-DECORATION: none;} 

.website A:hover {COLOR: #009900; TEXT-DECORATION: underline;} 

.website A:link {COLOR: #009900; TEXT-DECORATION: none;} 

.website A:active {COLOR: #009900; TEXT-DECORATION: underline;} 

  

.text { font-family: Verdana, Arial, Helvetica, sans-serif;  

        font-size: 12px;  

        color: #000000;  

        font-weight: bold;} 

 

.text A:visited {COLOR: #000000; TEXT-DECORATION: underline;} 

.text A:hover {COLOR: #009900; TEXT-DECORATION: underline;} 

.text A:link {COLOR: #000000; TEXT-DECORATION: underline;} 

.text A:active {COLOR: #000000; TEXT-DECORATION: underline;} 

 

.special {font-family: Verdana, Arial, Helvetica, sans-serif;  

          font-size: 12px;  

          color: #228B22;  

          font-weight: bold; }   

 

.table1 { font-family: Verdana, Arial, Helvetica, sans-serif;  

          font-size: 12px;  

          color: #666666;  

          background-color: #FFFFFF; 

          border: 13px solid #000000; }  

 

.table2 { font-family: Verdana, Arial, Helvetica, sans-serif;  

          font-size: 12px;  

          color: #666666;  

          background-color: #FFFFFF; 

          border: 1px solid #7F2DA7;} 

 
 

6. Open an empty text file in a text editor like Notepad. Copy and paste the 
following code into the editor. When you are done, save the file in the 
MyDemo folder as demoscreen.html 

 
<html> 

<head> 

<title>You are Playing a Trial Version of GAME NAME</title> 

<link rel="stylesheet" type="text/css" media="all" href="styles.css" /> 

</head> 

<body bgcolor="#FFFFFF"> 

<center> 

<table class="table1" cellspacing="0" cellpadding="0"> 

<tr> 

<td align="left" valign="top"> 

<table class="table2" border="0"> 

<tr> 

<td width="455" colspan="2" align="center"> 

<img src="title.jpg" width=”500” height=”100” border="0"> 

</td> 

</tr> 

<tr> 
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<td width="197" align="left" valign="top"> 

<a href=" purchase-page"><img src="buy.jpg" width=”167” height=”43” 

border="0"></a> 

</td> 

<td width="258" valign="top" align="left"><span class="prodPrice">$19.99 

USD</span></td> 

</tr><tr><td colspan="2"><table cellpadding="10"><tr><td> 

<span class="text"> 

This is a trial version of GAME NAME. The first part of the game is free, 

but to play the entire game, you need to <a href="http://www.purchase-

page.com">purchase it</a>.  

</span> 

</td></tr></table> 

</td> 

</tr> 

</table> 

</td> 

</tr> 

</table> 

</center> 

</body> 

</html> 

 
7. In demoscreen.html, modify following information for your game and save 

your changes. 

 GAME NAME: Replace this with the name of your game. 

 www.purchase-page.com: Replace this with the order page for your 
game. If you have not set this up, don’t worry. We will do this in the 
next section, which is called Get an Order Processor. 

 
Now, when you open demoscreen.html in a browser, you should see a page that 
looks like this: 
 

 

Create Your Demo 

Because you are not using a DRM, you must create a version of your game that 
only contains a few areas or limited gameplay. I can’t walk you through this part, 
but I’m sure you know what to do. Once you’ve created your demo and tested it, 
go on to the next section. 
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Attach Your Buy Now Page to Your Demo 

When you have created a demo for your customers, you need to link it to your 
buy now page. The buy now page should launch when your game launches AND 
when your game exits. 
 

1. Move the contents of the MyDemo folder into the folder that contains your 
demo.  

2. Open the source code for your demo. In the startup routine, make the 
game open demoscreen.html. 

3. In the exit routine, make the game open demoscreen.html. 
4. Test your game to make sure this file opens.  

Note: demoscreen.html should be in your demo folder, not on your web 
server. 

Finishing Up 

To finish up, you’ll need to complete the next section, Get an Order Processor.  
 
After you’ve done this, you need to create an installer for your demo. Don’t create 
the installer until you’ve set up your order processor. You’ll need to update an 
important link in demoscreen.html that you can only get from your order 
processor. 
 
When you’ve created an installer for your demo, upload your demo to your 
website. 
 
 

Get an Order Processor 
 Cost = 8-10% of all sales 

 My suggestion = Plimus 
 
You have reached the final stage that is required to sell your game! How are you 
feeling? Like you just ran a marathon? I don’t doubt it. You’re in the home 
stretch, so hang in there! 
 
To actually sell your game, you need an order processor. An order processor 
collects payments from your customers. For a small percentage, an order 
processor will take the payments for your game via credit cards, PayPal, mail, 
fax, phone, and camel.  
 
My favorite order processors are Plimus and BMT Micro. 
 
Note: You may have noticed that I did not list PayPal as an order processor. 
PayPal only take around 3-5% per sale, but it is a very limited order processor. It 
doesn’t take many payment forms, has poor transaction tracking, no piracy 



25 | P a g e  
 

protection, etc. Worse, when you do your taxes, you have to track every sale and 
pay taxes on these sales. AND your bank account will make you pay if you have 
too may transactions per month. With the other order processors, you don’t have 
to do this. You receive a royalty check every month. One bank transaction. No 
paying taxes per game sold. 
 
If an order goes through, the same order processor will send out an unlock key 
for your game to the person who bought it. Sounds like magic, eh? Not quite. The 
SoftwarePassport and Plimus people work together. I’ll show you how to plug 
SoftwarePassport and Plimus together in the next section, but for now, let’s get 
your order processor set up. 

DRM Order Processor Setup 

Use these steps ONLY if you already own SoftwarePassport. As of 2013, this 
product is no longer sold. There are other similar products on the web, but I’ve 
not tried them out. 
 

Set up Your Order Processor 

Creating an account with an order processor is free if you use Plimus or BMT 
Micro. In this section, I’m going to use Plimus since it is my preferred order 
processor. 
 

1. Go to http://home.plimus.com. 
2. Click Register. 
3. Complete the registration form. 

Note: You must have a valid website. If you haven’t set up your website, 
go back to the beginning of this guide for steps. 

4. Wait for Plimus to accept you as a seller (it can take a few days). 
5. Log into your Plimus Seller account: 

https://secure.plimus.com/jsp/developer_login.jsp 
6. Click New Product. 

http://home.plimus.com/
https://secure.plimus.com/jsp/developer_login.jsp
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7. Enter information about your product in the BuyNow Product Wizard: 

 
 

8. Click Submit. The Product Information page for your game opens. 
9. Scroll to the bottom of the page and click Full Version. 
10. On the General tab, modify the information about your product.  

WARNING: Do not change the BuyNow URL.  
11. Click Submit. 
12. Click Account. 
13. Click Shopper Experience > Email Templates. 
14. Create a new email template. Here are some example values: 

 Select template—Generic Email Template 

 Template name—Ninja Sword Games Purchase Order 

 Description—Send to people who have purchased a game. 

 From (email)—admin@ninjasword.com 

 Email subject—Order Confirmation & License Key – Ninja Sword 
Games 

 Content type—Plain text 

 Email body—Make sure to include <CUSTOMER_NAME>. This is very 
important because we are going to use it to generate keys in Plimus. 
----------------------------------------- 
Dear <CUSTOMER_NAME>, 
 
Thank you for ordering <PRODUCT_NAME> from Ninja Sword 
Games! The following email is a summary of your order. Please use 
this as your proof of purchase. 
 
HOW TO ACTIVATE THE FULL VERSION OF YOUR GAME 
-------------------------------------------------------- 
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1. If you have not installed your game, you can download it here: 
<PRODUCT_DOWNLOAD_URL> 
 
2. Open the game. 
 
3. When the Buy Now screen opens, click Enter Key.  
 
4. In the Name field, enter the name you used to purchase the game. 
Your Name is: <CUSTOMER_NAME>  
 
5. In the Key field, enter the key you received in this email. Your key is: 
<LICENSE_KEYS> 
 
 
TROUBLESHOOTING REGISTRATION 
-------------------------------------------------------- 
If you downloaded the game from another site and purchased the 
game from us, you need to install the game from our site. Do the 
following: 
 
1. Uninstall <PRODUCT_NAME> from your computer. 
 
2. Re-download <PRODUCT_NAME> from: 
http://www.ninjasword.com 
 
3. Reinstall <PRODUCT_NAME> (the one you just downloaded). 
 
4. Complete the activation steps that you followed earlier in the section 
above. 
 
Or, if you downloaded the game from us and your key doesn't work: 
 
1. Email us at admin@ninjasword.com to get a new key.  
 
 
QUESTIONS REGARDING DOWNLOAD,TECHNICAL SUPPORT & 
BILLING 
-------------------------------------------------------- 
For assistance with the product you have purchased, please contact 
admin@ninjasword.com or visit our website www.ninjasword.com. 
 
 
YOUR ORDER INFORMATION 
-------------------------------------------------------- 
Product Name:         <PRODUCT_NAME> 
Product Number:       <PRODUCT_NUMBER> 
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Order Number:         <INVOICE_ID> 
 
 
YOUR KEY INFORMATION 
-------------------------------------------------------- 
Name:   <CUSTOMER_NAME> 
Key:    <LICENSE_KEYS> 
 
 
GAME DOWNLOAD INFORMATION 
-------------------------------------------------------- 
If you already have <PRODUCT_NAME> installed, you do not need to 
re-download the game. If you need to re-download the game, you can 
get it here: http://www.ninjasword.com 
 
 
BILLING INFORMATION 
-------------------------------------------------------- 
<CUSTOMER_NAME> 
<CUSTOMER_ADDRESS1> 
<CUSTOMER_ADDRESS2> 
<CUSTOMER_CITY> <CUSTOMER_STATE> 
<CUSTOMER_ZIPCODE> 
<CUSTOMER_COUNTRY> 
<CUSTOMER_EMAIL> 
 
 
SHIPPING INFORMATION 
-------------------------------------------------------- 
If you added a CD to your order, the CD will be shipped to this 
address: 
 
<SHIPPING_FIRST_NAME> <SHIPPING_LAST_NAME>  
<SHIPPING_ADDRESS1> 
<SHIPPING_ADDRESS2> 
<SHIPPING_CITY> <SHIPPING_STATE> <SHIPPING_ZIPCODE> 
<SHIPPING_COUNTRY> 
 

15. Click Submit. Your template is saved with the name you entered in the 
Template Name field. 

16. Click Account. 
17. In the My Products List, click on your game. (For example, Sword Quest) 
18. On the General tab, click Full Version. 
19. Click Order Email.  
20. In the Select template field, select Ninja Sword Games Purchase Order 
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21. Click Submit. This is the email that will be sent when a customer 
purchases your game. 

22. Click Related Files/URLs > Paid Version. 
23. Upload your game’s installer exe through this page. Now, when someone 

purchases your game, they will be able to download it from the Plimus 
website. Although this sounds great, only people who have purchased 
something from you can do this, so you still need to host your game on 
your website. This feature also allows your users to purchase a CD when 
they buy your game from Plimus. 

 
Okay, we’re done for now. In the next section, I’ll show you how to make Plimus 
and SoftwarePassport work together. 

Connect SoftwarePassport to Plimus 

This makes the Buy Now button in the dialog box (appears when User starts 
new game / exits game) go to your order page on Plimus. 
 

1. Log into your Plimus Seller account: 
https://secure.plimus.com/jsp/developer_login.jsp 

2. In the My Products list, click your game. 
3. Scroll down to the bottom of the page and click Full Version. 
4. Copy the link in the Buynow URL field. 
5. Open the SoftwarePassport project for your game. 
6. Click on the License Key tab. 
7. In the Existing License Certificate Lists, select TrialLicense. 
8. In the Website Address field, paste the Buynow URL you copied in step 

4. (ex: https://www.plimus.com/jsp/buynow.jsp?contractId=9984468) 
9. Click the Build Project tab. 
10. Click Protect. 
11. Exit SoftwarePassport. 
12. Replace the old Game.exe in your game project with the newly wrapped 

Game.exe. 
13. Click on the DRM-wrapped Game.exe. When the dialog box pops up, click 

on the Buy Now button. Make sure that the order page for your game 
opens. 

https://secure.plimus.com/jsp/developer_login.jsp
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Connect Plimus to SoftwarePassport (Version 9) 

This step lets Plimus generate unlock keys for your game. When a user 
purchases your game, Plimus will immediately send an email with the unlock key 
to the user.  
 
Remember the order email text above? That’s what will be sent out to your users. 
Notice the section for the unlock key. 
 

1. Open the SoftwarePassport project for your game. (For example, Sword 
Quest) 

2. In the Project Tree, open to Project > Certificates > Purchase-License. 
3. Select the Name/Template tab. (By default, this should already be open) 
4. Click Unlock. 
5. Copy the value in the Encryption Template field. (ex: fdjaljfdfjladjfalsdf) 
6. Close SoftwarePassport. 
7. Log into your Plimus Seller account: 

https://secure.plimus.com/jsp/developer_login.jsp 
8. In the My Products list, click your game. 
9. Scroll down to the bottom of the page and click Full Version. 
10. Click License Keys. 
11. In the drop-down list, select Armadillo registration keys. 
12. The page reloads with lots of new fields. 
13. In the Armadillo Encryption Template field, paste the value you copied in 

step 5. 
14. In the Version list, select 3 (Short). 
15. In the Signature Level, select 10. 
16. In the Key String field, delete the existing value and enter: 

<CUSTOMER_NAME> 
17. Click Submit. 
18. Click General. 
19. Click Test BuyNow Flow. 
20. Fill out the dummy order form and submit. 
21. Check your email. You should get two emails. One to you (the Seller) and 

one for the customer. Pay special attention to the email for the customer. 
Make sure there are no spelling mistakes and most importantly, attempt to 
unlock your DRM-wrapped Game.exe with the key in the order email. If 
the key unlocks the game, great! If not, make sure the key template in 
your SoftwarePassport and Plimus project match. From my own 
experience, it is best to have a template with English letters in it. 

https://secure.plimus.com/jsp/developer_login.jsp
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DEMO Order Processor Setup 

Set up Your Order Processor 

Creating an account with an order processor is free if you use Plimus or BMT 
Micro. In this section, I’m going to use Plimus since it is my preferred order 
processor. 
 

24. Go to http://home.plimus.com. 
25. Click Register. 
26. Complete the registration form. 

Note: You must have a valid website. If you haven’t set up your website, 
go back to the beginning of this guide for steps. 

27. Wait for Plimus to accept you as a seller (it can take a few days). 
28. Log into your Plimus Seller account: 

https://secure.plimus.com/jsp/developer_login.jsp 
29. Click New Product 
30. Enter information about your product in the BuyNow Product Wizard: 

 
 

31. Click Submit. 
32. Scroll to the bottom of the page and click Full Version. 
33. On the General tab, modify the information about your product.  

WARNING: Do not change the Buynow URL.  
34. Click Submit. 
35. Click Account. 
36. Click Shopper Experience > Email Templates. 
37. Create a new email template. Here are some example values: 

 Select template—Generic Email Template 

 Template name—Ninja Sword Games Purchase Order 

 Description—Send to people who have purchased a game. 

http://home.plimus.com/
https://secure.plimus.com/jsp/developer_login.jsp
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 From (email)—admin@ninjasword.com 

 Email subject—Order Confirmation & License Key – Ninja Sword 
Games 

 Content type—Plain text 

 Email body—Make sure to include <CUSTOMER_NAME>. This is very 
important because we are going to use it to generate keys in Plimus. 
----------------------------------------- 
Dear <CUSTOMER_NAME>, 
 
Thank you for ordering <PRODUCT_NAME> from Ninja Sword 
Games! The following email is a summary of your order. Please use 
this as your proof of purchase. 
 
HOW TO ACTIVATE THE FULL VERSION OF YOUR GAME 
-------------------------------------------------------- 
Please download the full version of your game here: 
<PRODUCT_DOWNLOAD_URL> 
 
QUESTIONS REGARDING DOWNLOAD,TECHNICAL SUPPORT & 
BILLING 
-------------------------------------------------------- 
For assistance with the product you have purchased, please contact 
admin@ninjasword.com or visit our website www.ninjasword.com. 
 
YOUR ORDER INFORMATION 
-------------------------------------------------------- 
Product Name:         <PRODUCT_NAME> 
Product Number:       <PRODUCT_NUMBER> 
Order Number:         <INVOICE_ID> 
 
BILLING INFORMATION 
-------------------------------------------------------- 
<CUSTOMER_NAME> 
<CUSTOMER_ADDRESS1> 
<CUSTOMER_ADDRESS2> 
<CUSTOMER_CITY> <CUSTOMER_STATE> 
<CUSTOMER_ZIPCODE> 
<CUSTOMER_COUNTRY> 
<CUSTOMER_EMAIL> 
 
 
SHIPPING INFORMATION 
-------------------------------------------------------- 
If you added a CD to your order, the CD will be shipped to this 
address: 
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<SHIPPING_FIRST_NAME> <SHIPPING_LAST_NAME>  
<SHIPPING_ADDRESS1> 
<SHIPPING_ADDRESS2> 
<SHIPPING_CITY> <SHIPPING_STATE> <SHIPPING_ZIPCODE> 
<SHIPPING_COUNTRY> 
 

38. Click Submit. 
39. Click Account. 
40. In the My Products List, click on your game. (for example, Sword Quest) 
41. Click Full Version. 
42. Click Order Email. 
43. In the Select template field, select Ninja Sword Games Purchase Order 
44. Click Submit. 
45. Click Related Files/URLs > Trial Version. 
46. In the Trial Download URL field, enter the URL for your trial game. For 

example, http://www.ninjasword.com/swordquest-demo.exe 
47. Click Submit. 
48. Click Related Files/URLs > Paid Version. 
49. Upload your game’s full-version installer exe, using one of the following 

options on the upload page. 
 
Okay, we’re done for now. In the next section, I’ll show you how to make Plimus 
and your Demo work together. 

Connect Your Demo to Plimus 

This makes the Buy Now button in the dialog box (appears when User starts 
new game / exits game) go to your order page on Plimus. 
 

1. Log into your Plimus Seller account: 
https://secure.plimus.com/jsp/developer_login.jsp 

2. In the My Products  list, click on your game. 
3. Scroll down to the bottom of the page and click Full Version. 
4. Copy the link in the Buynow URL field. 
5. Open demoscreen.html in a text editor. 
6. In demoscreen.html, replace http://www.purchase-page.com with the 

Buynow URL that you copied in step 4. 
7. Play your demo. When the buy now dialog box opens, make sure that the 

buy now button goes to your order page on Plimus. 

Test Your Order Processor Setup 

 
1. Log into your Plimus Seller account: 

https://secure.plimus.com/jsp/developer_login.jsp 
2. In the My Products list, click on your game. 
3. Scroll down to the bottom of the page and click Full Version. 
4. Click General. 

http://www.ninjasword.com/swordquest-demo.exe
https://secure.plimus.com/jsp/developer_login.jsp
http://www.purchase-page.com/
https://secure.plimus.com/jsp/developer_login.jsp


34 | P a g e  
 

5. Click Test BuyNow Flow. 
6. Fill out the dummy order form and submit. 
7. Check your email. You should get two emails. One to you (the Seller) and 

one for the customer. Pay special attention to the email for the customer. 
Make sure there are no spelling mistakes.  
Note: You will not be able to download the full game in test mode. 

Beta Test Your Order System! 
After you have all of the sales mumbo jumbo set up, update your installer with 
the game and upload your new game installer to your website. Grab a bunch of 
new testers and make sure that your demo or DRM-wrapped game works as it 
should.  
 
If you are using DRM, practice making keys for your users in SoftwarePassport.  
(Load project in SP > Keys > Create Key > Click Purchase License > Enter 
User’s name in the Name to register this key to field > Generate.) 
 

Go Sell Your Game! 
And that’s all I have to say! Make sure that you update your installer with all of 
these changes. Then upload your game to your website. If any additional 
changes are made to your game, make sure to upload the new version to Plimus 
as well. 
 
Good luck and if you need help, let me know. 
 
Amanda Fitch 
Amaranth Games, LLC 
www.amaranthia.com 

http://www.amaranthia.com/

