join mailing list join Aveyond Kingdom on Twitter join Aveyond Studios on Facebook
We've created top-selling apps for iOS and Windows. What are we working on next? Games and tools! Browse our titles and maybe play a game or two. Want to chat? We have an active gaming community.

Jump to content

Aveyond 4: Shadow of the MistCurse at TwilightAveyond 3-4: The Darkthrop ProphecyA Gypsy's TaleAveyond 3-3: The Lost OrbAveyond 3-2: Gates of NightAveyond 3-1: Lord of TwilightYummy Drink FactoryAveyond 2: Ean's Quest
Photo

Script 'Window_SaveFile' line 44: ArgumentError occurred.


  • Please log in to reply
19 replies to this topic

#1 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 28 June 2012 - 07:21 PM

I've been replaying Aveyond 1, Build C. And today I tried to play it, and I got this window whenever I try to "continue quest".

Script 'Window_SaveFile' line 44: ArgumentError occurred.

negative length -123 given.


It also happens whenever I start a new game, and try to open the menu. I tried restarting my computer, to no avail. I've never had this problem before, and it's not happening on any of my other Aveyond games. Does anyone know what exactly this problem is, or how to fix it?

Thanks in advance!

#2 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 28 June 2012 - 11:05 PM

Is it possible you're trying to open a save file from Build B instead? It shouldn't matter - I don't think there were any changes to the way files were saved, and if there were, it wouldn't cause the error on a new game.

Try reinstalling the game, and see if that makes the problem go away.

If you still have the error when you start a new game, can you please post the exact error you get there? It may be a different line and/or a different script, so I want to make sure I'm looking in the right place.

#3 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 28 June 2012 - 11:11 PM

No, I don't own Build B, and I have Build A in a completely different file.

I'll try reinstalling it - but before I do so, that won't get rid of my save files, will it? (I've been playing this file for around 30 hours and am nearly at the battle with Ahriman, so I'd be pretty bummed if it did).

If I do, I'll screencap it.

Thanks a lot! :D

#4 Mopiece

Mopiece

    Dragon Lord

  • Moderators
  • 6,154 posts
  • LocationTexas

Posted 28 June 2012 - 11:20 PM

No, it won't get rid of your save files.

firedragon.png


#5 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 28 June 2012 - 11:22 PM

No, it won't mess up your save files. They're kept in a completely different area.

Again, I don't think it matters, but did you get build C from here, or from BFG (I don't think anyone else ever made it available)? And did you get it as soon as it was available, or was it long enough after release for any updates to have been posted? I don't remember if we put out a second version of build C or not, but we usually do have an update a week or two after release.

#6 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 28 June 2012 - 11:24 PM

Alright, thanks! I'll try that ASAP then.

#7 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 29 June 2012 - 05:50 PM

Alright, thanks! I'll try that ASAP then.

~

So it appears I've lost my Aveyond install file - would it work if I redownloaded it?

#8 Mopiece

Mopiece

    Dragon Lord

  • Moderators
  • 6,154 posts
  • LocationTexas

Posted 29 June 2012 - 05:54 PM

Yes, it'll work if you redownload the installer.

firedragon.png


#9 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 29 June 2012 - 06:06 PM

Alright. Then I am off to try that! Thank you :D

#10 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 29 June 2012 - 06:58 PM

Alright. Then I am off to try that! Thank you :D

~

Okay, it didn't work. Here is a screen cap of the exact error message -

[img width=300]http://i1100.photobucket.com/albums/g418/elemental494/aveyond-glitch.png[/img]

#11 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 29 June 2012 - 08:25 PM

Elemental, can you send me a copy of your save file?

Is the message when you load a save file, and the message when you start a new game, exactly the same?

#12 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 29 June 2012 - 08:29 PM

I would, but I don't know how to access my save files for Aveyond 1.

The problem isn't when I try to load a save file, but when I try to open the screen that shows my save file. As soon as I click "Continue Quest", I get this error message. I also get it when I try to begin a new game and it tells me to save. So I think the problem is related to the Load Save menu.

#13 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 29 June 2012 - 09:11 PM

Did you just reinstall, or did you actually redownload? And did you completely uninstall the old version first?

#14 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 29 June 2012 - 09:20 PM

Okay, I think I've been assuming some things, and I probably should ask ...

Your 30-hour game - was that ALL played in build C? Or did you start playing in build A and then download C afterwards? Have you EVER played that particular game in build C?

You can go to %appdata% and find the Aveyond I folder. Your save files are in there. I'm not sure where build A puts its save files - if it uses the same location, that's probably why it won't open for you - build A save files are not compatible with build C, and the save file window has to look inside ALL save files in that folder to show you their details. If you have build A and build C save files together, you should rename the build A files so they don't start with Save.

#15 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 30 June 2012 - 03:52 AM

The 30 hour game was entirely Build C. I've never touched this file in Build A before.

I don't think Build A uses the same location, as I've never encountered any saving problems before. Would you like me to send you the file now?

#16 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 30 June 2012 - 06:24 AM

Actually, I've got another idea.

Go to where the files are saved - %appdata% and into the Aveyond I folder.

There will be one or more files named Save#.rxdata where # is a number.

Rename ALL of them. Start a new game, see if it gives you the error. It shouldn't.

One at a time, rename the files back. After each one, play the game (you actually shouldn't have to exit) and go to the save file menu - either by trying to load a game from the menu, or starting a new game and being prompted to save.

At some point, it will fail. Whatever file you last renamed back to its original name will be the one that's causing the problem. When you find it, name it something else again, and continue through the list - there could be more than one.

HOPEFULLY, your 30-hour game won't be the offender. If it is, go ahead and email it to me.

#17 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 30 June 2012 - 03:28 PM

Alright. I'll go and try it out! Thank you so much for the help.

#18 Elemental

Elemental

    Advanced Member

  • Members
  • PipPipPip
  • 2,505 posts

Posted 30 June 2012 - 03:33 PM

Alright. I'll go and try it out! Thank you so much for the help.

~

Fixed it! Thank you SO MUCH - I think it *was* my 30 hour game, but luckily I had multiple saves in Ahriman's lair, so I have to redo very little - if anything at all.

Once again, thanks for all the help!

#19 shaz

shaz

    Advanced Member

  • Moderators
  • 11,577 posts

Posted 30 June 2012 - 07:55 PM

Wonderful!

#20 LaeLi

LaeLi

    Amaranthian

  • Members
  • 8 posts

Posted 09 April 2017 - 10:11 PM

didnt work for me ;-;






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users