Jump to content
Aveyond Studios Community
Sign in to follow this  
Elemental

Script 'Window_SaveFile' line 44: ArgumentError occurred.

Recommended Posts

I've been replaying Aveyond 1, Build C. And today I tried to play it, and I got this window whenever I try to "continue quest".

 

Script 'Window_SaveFile' line 44: ArgumentError occurred.

 

negative length -123 given.

 

It also happens whenever I start a new game, and try to open the menu. I tried restarting my computer, to no avail. I've never had this problem before, and it's not happening on any of my other Aveyond games. Does anyone know what exactly this problem is, or how to fix it?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Is it possible you're trying to open a save file from Build B instead? It shouldn't matter - I don't think there were any changes to the way files were saved, and if there were, it wouldn't cause the error on a new game.

 

Try reinstalling the game, and see if that makes the problem go away.

 

If you still have the error when you start a new game, can you please post the exact error you get there? It may be a different line and/or a different script, so I want to make sure I'm looking in the right place.

Share this post


Link to post
Share on other sites

No, I don't own Build B, and I have Build A in a completely different file.

 

I'll try reinstalling it - but before I do so, that won't get rid of my save files, will it? (I've been playing this file for around 30 hours and am nearly at the battle with Ahriman, so I'd be pretty bummed if it did).

 

If I do, I'll screencap it.

 

Thanks a lot! :D

Share this post


Link to post
Share on other sites

No, it won't mess up your save files. They're kept in a completely different area.

 

Again, I don't think it matters, but did you get build C from here, or from BFG (I don't think anyone else ever made it available)? And did you get it as soon as it was available, or was it long enough after release for any updates to have been posted? I don't remember if we put out a second version of build C or not, but we usually do have an update a week or two after release.

Share this post


Link to post
Share on other sites

Elemental, can you send me a copy of your save file?

 

Is the message when you load a save file, and the message when you start a new game, exactly the same?

Share this post


Link to post
Share on other sites

I would, but I don't know how to access my save files for Aveyond 1.

 

The problem isn't when I try to load a save file, but when I try to open the screen that shows my save file. As soon as I click "Continue Quest", I get this error message. I also get it when I try to begin a new game and it tells me to save. So I think the problem is related to the Load Save menu.

Share this post


Link to post
Share on other sites

Okay, I think I've been assuming some things, and I probably should ask ...

 

Your 30-hour game - was that ALL played in build C? Or did you start playing in build A and then download C afterwards? Have you EVER played that particular game in build C?

 

You can go to %appdata% and find the Aveyond I folder. Your save files are in there. I'm not sure where build A puts its save files - if it uses the same location, that's probably why it won't open for you - build A save files are not compatible with build C, and the save file window has to look inside ALL save files in that folder to show you their details. If you have build A and build C save files together, you should rename the build A files so they don't start with Save.

Share this post


Link to post
Share on other sites

The 30 hour game was entirely Build C. I've never touched this file in Build A before.

 

I don't think Build A uses the same location, as I've never encountered any saving problems before. Would you like me to send you the file now?

Share this post


Link to post
Share on other sites

Actually, I've got another idea.

 

Go to where the files are saved - %appdata% and into the Aveyond I folder.

 

There will be one or more files named Save#.rxdata where # is a number.

 

Rename ALL of them. Start a new game, see if it gives you the error. It shouldn't.

 

One at a time, rename the files back. After each one, play the game (you actually shouldn't have to exit) and go to the save file menu - either by trying to load a game from the menu, or starting a new game and being prompted to save.

 

At some point, it will fail. Whatever file you last renamed back to its original name will be the one that's causing the problem. When you find it, name it something else again, and continue through the list - there could be more than one.

 

HOPEFULLY, your 30-hour game won't be the offender. If it is, go ahead and email it to me.

Share this post


Link to post
Share on other sites

Alright. I'll go and try it out! Thank you so much for the help.

 

~

 

Fixed it! Thank you SO MUCH - I think it *was* my 30 hour game, but luckily I had multiple saves in Ahriman's lair, so I have to redo very little - if anything at all.

 

Once again, thanks for all the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×