Jump to content
Aveyond Studios Community
Sign in to follow this  
marshach

Script 'Window_SaveFile' line 39: EOFError occured

Recommended Posts

Please help! I am nearing the end of the game. This evening when I started Aveyond and selected "Load Quest" I immediately get a Windows error message:

 

Script 'Window_SaveFile' line 39: EOFError occured

 

End of file reached.

Share this post


Link to post
Share on other sites

Did you get the screen where you can select which save file you want to load? If not, it sounds as if your autosave file is corrupt. Find your save files (the pinned topic at the top of this forum will give you the location), and delete the file named Save0.rxdata (or better, rename it to Save0.rxdatabak or something like that). Then see if you can load any save files.

Share this post


Link to post
Share on other sites

I tried to start a new quest to see if maybe I could load my old one from there. What happened is that shortly after the game began there was a dialogue box with a message something like "The first thing you should do is save your game.." The same error occurred immediately and the game closed.

Share this post


Link to post
Share on other sites

did you remove your Save0 file? It sounds like that's the one causing the problem. Have a go at that, and then see if you can reload your original save, at the end of the game. It should also overcome your latest problem.

Share this post


Link to post
Share on other sites

shaz -

 

You asked: "Did you get the screen where you can select which save file you want to load?"

 

No, I can't even get as far as select which saved game I want. The error occurs as soon as I select "Load Quest" on the main screen.

 

I tried what what you suggested: I renamed Save0.rxdata to Save0.rxdatabak and then tried to start the game again. As soon as I hit "Load Quest" I get the same error.

 

Edit: By the way, I had not seen your original reply yet when I submitted my second posting in this thread. I did not know anyone had even replied yet. Sorry for the confusion.

Share this post


Link to post
Share on other sites

that's ok - I thought your response was pretty quick :)

 

I'm sorry - if that doesn't help, I'm not sure what the next step is. If you have your installation program, you might try reinstalling the game. I don't know if that will solve the problem, but it's something I'd try myself at this point.

 

If that doesn't work, post back here, and hopefully Bryce will be able to answer you.

Share this post


Link to post
Share on other sites

shaz - In another posting for the same problem Brycej recommended the user email the saved file to admin@amaranthia.com to see if they could fix it. Is that a possibility? I'm afraid if I re-install the entire program I might lose my saved games.

Share this post


Link to post
Share on other sites

your saved games are not saved with the program - they're tucked away somewhere safe.

 

However, if your problem is the same one mentioned in THAT post, Bryce has already confirmed the save file is the problem. Issue is - if you've already renamed your Save0.rxdata and the problem is still happening, which save file is the one causing the trouble, and the one that you'd email? Reinstalling the game won't make a difference, in this case. But I do see Bryce online, so hopefully he's got enough time to check your thread and offer some advice.

Share this post


Link to post
Share on other sites

"Curiouser and curiouser!"

 

I think something is seriously wrong with Save0.rxdata and Save1.rxdata. Those are the two most recent saved files, but the size of Save0 is only 89 KB, and the byte count of Save1 is only 6 KB. All the older saved games are larger files (over 100 KB).

Here are the troubleshooting steps I've taken:

1. Signed on to my computer with the admin account instead of my usual account (I'll call it the "marshach" account.)

2. Copied Save2 from my marshach account to the Admin account. I was then able to open the game and load Save2. As a further step, I copied Save1 from my marshach to the Admin account, overwriting the Save1 file that was already there. After that, I began seeing the same exact error I was getting originally. So, I think my Save1 file is corrupted.

3. Finally, I tried replacing the Admin's Save0 with marshach's Save0. The strange thing is that marshach's Save0 appears to be a brand new game (Ean only). I don't know for sure, but I suspect that when I attempted to start a new quest (when I was signed on with the marshach account) my old Save0 (the one I wish I could use) was overwritten.

 

Well, the "bottom line" is that I can now open the game and Save2 is good, so I'll just start from there. I'll lose a few hours of game play, but that's better than losing everything.

 

Thanks, Shaz, for your time and suggestions.

Share this post


Link to post
Share on other sites

Well, the "bottom line" is that I can now open the game and Save2 is good, so I'll just start from there. I'll lose a few hours of game play, but that's better than losing everything.

 

Thanks, Shaz, for your time and suggestions.

Share this post


Link to post
Share on other sites

you're welcome, though I didn't help a whole lot...

 

When you renamed Save0.rxdata earlier, was that before you started a new game, or after? If it was after, then you could just try renaming it back to its original name, and that should be a fairly recent one.

 

Seems your Save1 was the problem...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×